В Linux 5.14 откажутся от устаревшей реализации поддержки IDE-накопителей

 

Из ядра Linux 5.14 собираются убрать устаревший код. Это позволит уменьшить размер ядра, которое «похудеет» более чем на 41 тыс. строк кода, и отказаться от устаревших зависимостей. Как сообщает ресурс Phoronix, речь идёт о старой реализации поддержки IDE (/dev/hdx), которая была помечена как запрещённая к использованию ещё пару лет назад.

Впрочем, ей всё равно вряд ли кто-либо пользовался в последнее десятилетие. При этом поддержка старого оборудования останется, так как более современная реализация на базе libata никуда не денется. А старый код уже удалён из Linux 5.14. В будущем планируется убрать его зависимости и другие связанные данные, что позволит ещё больше уменьшить размер ядра.

wikipedia.org

wikipedia.org

Пока что не сообщается, какие ещё устаревшие подсистемы могут удалить в Linux 5.14, однако, похоже, назрела «генеральная уборка». Напомним, что пару лет назад из ядра убрали поддержку флоппи-приводов. Крупные дистрибутивы также занялись оптимизацией под более современное «железо» — в RHEL 9 повысятся минимальные требования к CPU, а SUSE планирует предоставлять несколько версий системных библиотек для различных наборов инструкций x86-64.

Если вы заметили ошибку — выделите ее мышью и нажмите CTRL+ENTER. | Можете написать лучше? Мы всегда рады новым авторам.

Источник:

Постоянный URL: https://servernews.ru/1043152

Комментарии

Система Orphus